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Unable to Delete Volume From HPE 3PAR With Error "VolumeIsBusy: resource in use
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Problem
- OpenStack volume fails to delete even though the volume is in a detached and available state.
- The following error is observed in Cinder logs ( /var/log/pf9/cinder-volume-base.log) on the block storage host.
ERROR cinder.volume.drivers.hpe.hpe_3par_common [...] Exception: Conflict (HTTP 409) 34 - resource in use: HTTPConflict: Conflict (HTTP 409) 34 - resource in use...ERROR cinder.volume.manager [...] Unable to delete busy volume.: VolumeIsBusy: resource in useEnvironment
- Platform9 Managed OpenStack - All Versions
- Cinder
- HPE 3PAR
Cause
- The volume fails to delete because of a stale export present in the 3PAR storage.
- The stale export could be caused because of a failed live migration attempt on the instance using this volume.
- When a volume is in a detached and available state, there should be no export present in the 3PAR UI.
Resolution
- Log into the 3PAR management console and search for the volume using comments as the filter since Platform9 saves the volume UUID in the comments section of the volume.
- Once you successfully locate the volume, check the entries in the 'Exports' section of the volume properties.
Note: The UUID mentioned in the 'Exports' section indicates the host UUID on which the instance using the volume used to reside.
- Create a test instance.
- Migrate the test instance to the host on which the volume already has an export.
- Attach the volume to be deleted to this test instance.
- Once the volume is attached successfully, detach it from the test instance.
- Confirm that the 'Exports' section in the 3PAR UI is empty.
- Refresh the Platform9 UI to confirm that the volume is now detached and in an available state.
- Delete the volume using the Platform9 UI.
Note: If the volume fails to detach from the test instance, try deleting the test instance.
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