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Single-Sign On (SSO) Authentication Loop With Azure AD
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Problem
After attempting to "Sign In With SSO" and successfully authenticating with the Azure AD provider, the browser is re-directed back to the Platform9 UI login page.
Environment
- Platform9 Managed Kubernetes – All Versions
- Platform9 UI
- Authentication/Single-Sign On (SSO)
- Azure/Active Directory (AD)
Cause
SAML assertion is failing due to a missing Group Claim in the Azure application.
Resolution
- Ensure a group claim exists under the "Attributes and Claims" section of the app, and that it matches the type "Security Group" with a Source attribute of "sAMAccountName".
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