Platform9 Generic
Latest
Frequently Asked Questions
How To
Solution
Internal Only
Templates
Powered By

Title
Message
Create new category
What is the title of your new category?
Edit page index title
What is the title of the page index?
Edit category
What is the new title of your category?
Edit link
What is the new title and URL of your link?
Host Reporting Offline in Clarity UI
Copy Markdown
Open in ChatGPT
Open in Claude
Problem
The Clarity UI reports the host as "offline" even though it is up and running.
Environment
- Platform9 Managed OpenStack - All Versions
- Platform9 Managed Kubernetes - All Versions
Cause
One or more of the following can be the possible cause(s).
Disk Utilization is 100%
The Hostagent daemon logs its events to /var/log/pf9/hostagent.log.
In an event where the /var file system gets full, Hostagent will fail to log, thus failing to send heartbeats to the Management Plane
Check the disk usage.
xxxxxxxxxxdf -h /varPlatform9 Hostagent and/or Comms Service may not be Running
- Check the status of the services.
xxxxxxxxxxsystemctl status pf9-hostagent.service pf9-comms.serviceHost Unable to Communicate With Management Plane: "ETIMEDOUT"
Stalled vgs Execution
- The pf9-hostagent daemon collects certain system utilization information like
vgs, which at times can stall if LVM filters are not set. - Check whether the vgs process is running.
- The pf9-hostagent daemon collects certain system utilization information like
xxxxxxxxxxps -ef | grep vgsSystem Load Average is High
- When all the CPUs are consumed, the pf9-hostagent fails to get a CPU cycle. As a result, pf9-hostagent is unable to send a heartbeat to the Management Plane.
- Check the system load average using the
toporuptimecommand. - Check the number of CPUs on the host/node using the
lscpucommand. - If the system load average is greater than the number of CPUs, identify the source of the load. However, if the load is genuine, increase the number of CPUs.
Platform9 Hostagent Daemon is Taking Too Long to Generate A Support Bundle
- When the command to generate a support bundle is fired, it pulls all the logs from /var/log/pf9.
- If the size of the directory is greater than 2GB, it takes time to copy and compress the logs.
- As pf9-hostagent is a single-threaded process, it will neither log events to /var/log/pf9/hostagent.log nor send heartbeats to the Management Plane, until the support bundle is generated.
- Check if the process is in a 'D' (defunct) state.
$ ps aux | grep hostagent pf9 23903 0.0 0.0 113132 1204 ? Ss Jan04 0:00 /bin/bash -c /opt/pf9/hostagent/bin/pf9-hostd >> /var/log/pf9/hostagent-daemon.log 2>&1 pf9 23904 0.3 0.0 393408 67824 ? D Jan04 406:16 /opt/pf9/hostagent/bin/python /opt/pf9/hostagent/bin/pf9-hostd $Resolution
Resolve based on the respective cause(s) stated above.
VariableType to search · ESC to discard
GlossaryType to search · ESC to discard
InsertType to search · ESC to discard
No matches
Last updated on
Was this page helpful?
Discard Changes
Do you want to discard your current changes and overwrite with the template?
Archive Synced Block
Message
Create new Template
What is this template's title?
Delete Template
Message